VASmalltalk – ZMQ Binding under Ubuntu 12.04LTS/64

Ubuntu 12.04LTS/64 comes with zmq 2.1.11 installable – which is a stable and relative new version – but of course only the 64bit version.

Therefore you have to install the 32bit version of the library via:

sudo apt-get install libzmq1:386

and in your ini-file (Linux installation of VASmalltalk) of your VASmalltalk application you should add an entry for mapping a logical filename to the specific library name:

[PlatformLibrary Name Mappings]
....

libzmq=libzmq.so.1

and you can verify the result by executing:

ZMQCore libraryVersion

which should return an array with the number 2, 1, 11.

This entry was posted in Smalltalk and tagged , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s